Some instant payments may be delayed right now
Incident Report for 86 400
Resolved
This incident has been resolved.
Posted Jun 23, 2021 - 15:50 AEST
Identified
Instant payments into and out of your account may be delayed right now. We are working to resolve the issue and any payments already made will reach your account. All other services remain available and we’ll update this page the second it's fixed.
Posted Jun 23, 2021 - 13:55 AEST
This incident affected: Our app.