New customers are unable to join 86 400 right now.
Incident Report for 86 400
Resolved
This incident has been resolved.
Posted 12 days ago. Sep 06, 2019 - 16:55 AEST
Identified
We’re working to resolve this as quickly as possible and we’ll update this page the second it’s fixed.
Posted 12 days ago. Sep 06, 2019 - 16:03 AEST
This incident affected: Our app.