New customers are unable to join us right now
Incident Report for 86 400
Resolved
This incident has been resolved.
Posted Apr 13, 2022 - 20:46 AEST
Identified
We’re working to resolve this as quickly as possible and we’ll update this page the second it’s fixed.
Posted Apr 13, 2022 - 16:46 AEST
This incident affected: Our app.