Our app’s unavailable right now
Incident Report for 86 400
Resolved
This incident has been resolved.
Posted Apr 20, 2022 - 17:27 AEST
Identified
We’re working to get it up and running as quickly as possible and we’ll update this page the second it’s fixed.
Posted Apr 20, 2022 - 17:03 AEST
This incident affected: Our app.