Our call centre’s unavailable right now
Incident Report for 86 400
Resolved
This incident has been resolved.
Posted Dec 02, 2019 - 17:53 AEDT
Update
We are continuing to work on a fix for this issue.
Posted Dec 02, 2019 - 17:14 AEDT
Identified
Unfortunately we’re experiencing a few issues with our contact centre right now. While we’re working on it please email us at hello@86400.com.au or try back a little later.
Posted Dec 02, 2019 - 17:13 AEDT
This incident affected: Call centre.