Recent transactions are taking a while to appear
Incident Report for 86 400
Resolved
This incident has been resolved.
Posted Feb 10, 2022 - 15:47 AEDT
Identified
But don't worry, any transactions you've made have gone through and your account balance is up to date. We'll update this page as soon as transactions appear in the app.
Posted Feb 10, 2022 - 14:24 AEDT
This incident affected: Our app.