Save Accounts
Incident Report for 86 400
Resolved
This incident has been resolved.
Posted Apr 08, 2022 - 15:00 AEST
Identified
Sorry, we can't open more than 3 Save accounts right now. We’re on it, and we’ll let you know when this feature is available.
Posted Apr 05, 2022 - 19:56 AEST
This incident affected: Our app.