Recent transactions are taking a while to appear
Incident Report for 86 400
Resolved
This incident has been resolved.
Posted Aug 11, 2021 - 19:12 AEST
Identified
But don’t worry, any transactions you’ve made have gone through and your account balances are up to date. We’ll update this page the second the transactions appear in the app.
Posted Aug 11, 2021 - 17:31 AEST
This incident affected: Our app.