Our app’s unavailable right now
Incident Report for 86 400
Resolved
This incident has been resolved.
Posted Nov 17, 2020 - 15:50 AEDT
Identified
We’re working to get it up and running as quickly as possible and we’ll update this page the second it’s fixed.
Posted Nov 17, 2020 - 15:24 AEDT
This incident affected: Our app.