Our website is down
Incident Report for 86 400
Resolved
The website is back up and running.
Posted Sep 30, 2021 - 10:02 AEST
Identified
Our website (www.86400.com.au) is currently not available due to an outage at one of our partners.
We will let you know as soon as it's back up, all other 86 400 services are still available.
Posted Sep 30, 2021 - 09:53 AEST