Our app’s unavailable right now
Incident Report for 86 400
Resolved
This incident has been resolved.
Posted Sep 04, 2021 - 07:50 AEST
Investigating
We’re working to get it up and running as quickly as possible and we’ll update this page the second it’s fixed.
Posted Sep 04, 2021 - 06:34 AEST
This incident affected: Our app.